Error: Cannot connect to vcenter_fqdn Cause: Cannot complete login due to an incorrect user name or password
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Error: Cannot connect to vcenter_fqdn Cause: Cannot complete login due to an incorrect user name or password

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Article ID: 438379

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Updated On:

Products

VCF Operations VMware Cloud Foundation

Issue/Introduction

VMware Cloud Foundation (VCF) Instance precheck fails with Cannot connect to vcenter_fqdn Cause: Cannot complete login due to an incorrect user name or password. #####
Failed on ### ##, ####, ##:##:## ##

Environment

  • VCF 9.x
  • VCF Operations 9.x

Cause

In most cases, this is due to a mismatch in the password of the account between the Software-Defined Data Center (SDDC) database and the target vCenter Server service account.

Resolution

  1. Obtain the service account credentials (secret) by Retrieve the service accounts credentials from SDDC Manager
    1. Note:- output "secret" is the password that VMware Cloud Foundation (VCF) is trying to use.  
  2. Update account in vCenter with the password you obtained following the KB.
    1. Log into vCenter UI.
    2. Click on the Menu at the top left and select Administration.
    3. Under "Single Sign On" click on "Users and Groups".  
    4. On the drop down to select the domain, select "vsphere.local".
    5. Find the service account that has the issue and select it.
    6. Click Edit and input the password 
  3. Restart the SDDC services using the command : /opt/vmware/vcf/operationsmanager/scripts/cli/sddcmanager_restart_services.sh