Inventory sync fails when a decommissioned ESX host (disconnected/not responding) still shows up in vCenter inventory.
search cancel

Inventory sync fails when a decommissioned ESX host (disconnected/not responding) still shows up in vCenter inventory.

book

Article ID: 438359

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • ESX host has been decommissioned from SDDC.

  • ESX host is powered off for a rebuild.
  • Stale ESX host showing as Disconnected / Not Responding in vCenter inventory.

Environment

VCF 9.x

SDDC 9.x

vCenter 9.x

Cause

Stale ESX host is showing in vCenter as Disconnected / Not Responding.

Resolution

Remove the stale ESX host from the vCenter inventory.

Re-sync Inventory:

VCF Operations > Inventory > VCF Instances > VCF domain > Actions > Sync Inventory

Additional Information

Out-of-band changes in VCF 9.0 can also cause Sync Inventory from VCF operation fails - Import operation for sync with id ###-###-###-### failed internally.

Note, When users remove the dead hosts directly from vCenter instead of using VCF remove domain workflows, issues may arise later down the road when attempting to remove the host from VCF.