Unable to get to IDM UI
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Unable to get to IDM UI

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Article ID: 438329

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Users are unable to access the UI, and logins are failing for other integrated products. The following errors are observed in the Windows connector logs:

Failed to fetch connector

Failed to check service health: invalid MOL url

Environment

VMware Identity Manager 3.3.7

external Windows connector

Cause

The config- state.json file for the Windows connector became corrupted or invalid, preventing communication with the tenant nodes.

Resolution

  • Navigate to the Windows Control Panel > Programs and Features.

  • Locate VMware Identity Manager Connector and select Uninstall.

  • Manually delete the residual installation directory (default: C:\VMware\Identity-Manager-Connector) to ensure corrupted configurations or keystores are entirely purged.

  • Execute the vIDM Connector Installer executable (.exe) to perform a clean installation Run the VMware Identity Manager Connector Installer - Broadcom TechDocs.

  • Access the primary vIDM administrative console (https://<vIDM FQDN>/SAAS/login/0) and navigate to Identity & Access Management > Setup > Connectors.

  • Delete the Windows connector
  • Select New to generate a new Activation Code Run the VMware Identity Manager Connector Installer - Broadcom TechDocs.

  • Access the newly rebuilt Windows connector UI (https://localhost:8443/) and paste the Activation Code to re-establish trust with the vIDM cluster.

  • Make sure the config-state.json file on the Windows server lists the hostname for the vIDM VIP rather than the Windows server hostname.