Upgrade error "Check for duplicate usernames.: Conflicting username "username" found in new version. Please rename user "username" with different username during NSX upgrade"
search cancel

Upgrade error "Check for duplicate usernames.: Conflicting username "username" found in new version. Please rename user "username" with different username during NSX upgrade"

book

Article ID: 438299

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX-T upgrade failed with an error while precheck "Conflicting username <username> found in new version. Please rename user <username> with different username".
  • When trying to get user details using the API curl -k -u admin -X GET "https://<nsx-manager-ip>/api/v1/node/users/<user-id>", we get the error message as {"error_code": 258, "error_message": "The requested URI: /api/v1/node/users/<user-id> could not be found.", "module_name": "common-services"}
  • Latest NSX manager log file /var/log/proton/nsxapi.log on NSX manager suggests "The requested URI: /api/v1/node/users/<user-id> could not be found. (Error code: 258)"

Environment

VMware NSX 

Cause

The affected username has different user IDs in the NSX UI and the Corfu database.

Resolution

Reach out to Broadcom support team referencing this KB. 

Opening and managing Broadcom SR https://knowledge.broadcom.com/external/article/142884/creating-and-managing-broadcom-support-c.html