OnPrem AWI Login Error "No connection to ... CPs ... jcp-ws-1:8443"
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OnPrem AWI Login Error "No connection to ... CPs ... jcp-ws-1:8443"

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Article ID: 438223

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Users are unable to log in to the Automic Web Interface (AWI). The following error is displayed: No connection to the following CPs could be established: jcp-ws-1:8443 Please make sure that the system meets the minimum requirement for processes and that it uses WS.PORT to establish the connection.

 

Environment

Automic Automation v24.4.3

Cause

Defect (DE182534) in the JavaAPI WebSocket implementation causes the JCP to incorrectly maintain an old connection ID. When the AWI attempts to reconnect, the JCP flags it as a duplicate (U00045419), suspending the new connection.

Resolution

This problem has been fixed in 24.4.4+HF1

 

Workaround

To workaround this issue until you can upgrade/apply 24.4.4+HF1, follow the steps below.

Step 1:

Modify the /etc/sysctl.conf file to adjust the TCP keepalive settings.

Note: Tomcat might only reside on one compute node (e.g., compute 2), but these settings must be applied to both servers because the AWI connects to the JCP across both.

Add the following lines to /etc/sysctl.conf:

net.ipv4.tcp_keepalive_time = 60

net.ipv4.tcp_keepalive_intvl = 10

net.ipv4.tcp_keepalive_probes = 3

 

Step 2: Restart Services

For the changes in /etc/sysctl.conf to take effect, a restart is required.

  • Preferred Method: Restart the server or Tomcat.
  • Temporary/Immediate Workaround: If you are unable to apply the configuration changes and do a full restart immediately, you can temporarily resolve the outage by manually restarting Tomcat (kill the AWI process and start it once again).