Users intermittently encounter a generic API-1019 error message (red toast notification) while navigating or performing updates in the Clarity Modern UX (MUX).
Environment
Any Supported Clarity Releases
Cause
API-1019 is a generic error. The actual root cause is only available in the app-ca.log or/and through a HAR file trace.
API-1019 is a high-level wrapper error used by the Modern UX when a REST API request fails.
Because it is a generic "catch-all" message, the root cause may vary significantly between occurrences.
Resolution
Any time you see this specific generic error API-1019 in MUX, it has to be matched with Clarity logs and HAR for proper root cause analysis
Each API-1019 error occurrence, even if on the same screen, may be having a separate root cause and be resolved by a different fix
Troubleshooting Suggestions:
Generate a Network Trace - HAR File
Open the Developer Tools in your browser and select the Network tab.
Reproduce the error in the Modern UX.
Look for a failed REST call - typically highlighted in red with a status code such as 400, 403, or 500
Analyze the app-ca.log for the specific error message thrown with the same user at the same time
Take the specific error message found and search the Broadcom Knowledge Base for a matching solution published by Broadcom.
If the issue persists and no matching KB is found, please open a case with Broadom Support with the following:
app-ca.log covering the timeframe of the error
HAR file captured during reproduction.
screenshot of the error in the UI.
username and exact steps to reproduce.
with these details, Broadcom Support will assist you