Log file contains pipe symbols and question marks, but no messages
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Log file contains pipe symbols and question marks, but no messages

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Article ID: 438163

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation Automic Automation

Issue/Introduction

When starting a component, the log file contains a Ucode (like U02000000), some phrases, pipe symbols - | - and a lot of questions marks, but does not give good messages.  For example, a windows agent log might look like the following:

20260424/143111.666 - U02000000 2000000? WIN01|24.4.4+build.1771583108722|1771583108|
20260424/143111.667 - U02000232 2000232? 2026-02-20|11:25:08|
20260424/143111.667 - U02000037 2000037? C:\automic\Agents\WIN01\bin\UCXJWX6.ini|
20260424/143111.668 - U02000090 2000090? 17.0.14|
20260424/143111.668 - U02000421 2000421? OpenJDK Runtime Environment|
20260424/143111.668 - U02000091 2000091? Eclipse Adoptium|
20260424/143111.669 - U02000113 2000113? C:\automic\Agents\WIN01\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Program Files\Eclipse Adoptium\jdk-17\bin|
20260424/143111.670 - U02000192 2000192? Windows Server 2019|10.0|
20260424/143111.670 - U02000193 2000193? amd64|
20260424/143111.671 - U02012087 2012087? UTF-8|
20260424/143111.671 - U02000110 2000110? 8192|
...
20260424/143111.700 - U02000071 2000071? C:\automic\Agents\WIN01\bin|
20260424/143111.700 - U02000360 2000360? WIN01|8304|
20260424/143111.700 - U02000066 2000066? server|ip|
20260424/143111.718 - U00003450 3450? 9000090000000000|
20260424/143111.746 -           Automic system properties:
20260424/143111.750 -               automic.ft.omit.user.home: false
20260424/143111.750 -               automic.java.websocket.client: TRUE
20260424/143111.752 - U02001077 2001077? NT AUTHORITY\SYSTEM|
20260424/143111.752 - U02001079 2001079? 
20260424/143111.752 - U02001081 2001081? Service-0x0-3e7$|Automic-Station$|

Cause

The uc.msl file is either missing from the component's /bin directory or unable to be read by the user starting the component

Resolution

  1. Stop the component
  2. Go to the image or zip file from when you downloaded the component
  3. Find the *.msl file (may be called uc.msl or ucx.msl)
  4. Copy the *.msl file into the components /bin (or other start) directory
  5. Make sure the user starting the component has read access to the *.msl file
  6. Start the component

If the same issue occurs, open a case with Support and include a dir or ls -l of the component's /bin directory and the log file.