NSX Edge router (FRR) logs are not logging
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NSX Edge router (FRR) logs are not logging

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Article ID: 438151

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Updated On:

Products

VMware NSX

Issue/Introduction

The /var/log/vrr/vrr.log files are not incrementing.
Even after a reboot of the Edge node this does not change.

You can see in the /var/log/nsx-cli/nsx-cli.log the entry logged:

2024-02-27T21:04:01.798Z 2978442 cli.server.cli_command_service INFO {10000} CMD: set service router logging-level file off
2024-02-27T21:04:02.839Z 2978442 cli.audit INFO CMD: set service router logging-level file off (duration: 1.040s), Operation status: CMD_EXECUTED

Cause

This is expected behavior as the router logging has been turned off manually.

NOTE: This will also log if the service logging level has been manually changed, like as to "debug".

Resolution

To re-enable router (FRR) logging to frr.log, use the following command logged in to the Edge as admin: 

set service router logging-level file info