Scheduled report fails with API-1007
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Scheduled report fails with API-1007

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Article ID: 438145

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Updated On:

Products

Clarity FedRAMP Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

A user with limited rights is able to view a given report, but the schedule generated fails with the following error on the logs

User myuser tried to GET resource [resource name: reports, resource id: 5060063] but does not have permission.
CustomerResourceHandler ::  exception occurred while performing action:retrieve
com.ca.ppm.rest.exception.AuthException: API-1007 : You are not authorized to process request. Contact your system administrator for necessary security rights.
    at com.ca.platform.osf.object.rest.provider.ODFResourceProvider.handleAuthorizationException(ODFResourceProvider.java:4016)

The access rights granted to the user are:

Global rights:
  • Reporting - Available Reports - Navigate
  • Reporting - Navigate
  • Reporting - Report Schedule - Create
  • Reporting - Reports - Navigate
  • Reporting - Reports Library - Navigate
  • Reporting - Scheduled Reports - Navigate
Instance rights:
  • Reporting - Report Viewer – View (Over Broadcom's sample Report)

Is there any additional access right needed to schedule a report the user is able to view?

Environment

Clarity 16.4.X

Cause

User does not have necessary rights

Resolution

The following access right is needed to schedule a given report

It can be granted at instance level: 

Reporting - Report Designer - Edit (Over Broadcom's sample Report)