Flows not seen for a the vCenter datasource on VCF Operations for networks.
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Flows not seen for a the vCenter datasource on VCF Operations for networks.

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Article ID: 438003

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

  • Flow collection has stopped for the Distributed Virtual Switch (DVS) portgroups in VCF Operations for Networks.
  • This happens because NetFlow was turned on through the Cisco ACI controller instead of through the VCF Operations for network interface.
  • In this situation, we donot see any flows reported on the VCF Operations for Networks.

 

Environment

VCF Operations for Networks

Cause

The problem is a setup conflict. When you enable NetFlow directly on Cisco ACI, it takes over the flow settings.

This often blocks or changes the data that the VMware virtual switch sends out.

Since VCF Operations for Networks expects specific settings to "read" the traffic, the external change from ACI causes the data stream to break.

 

Resolution

To fix this, you must let VCF Operations for Networks handle the flow settings:

  1. Turn off the NetFlow policies on your Cisco ACI that point to the VCF portgroups.

  2. Open the VCF Operations for Networks console.

  3. Go to Settings > Accounts and Sources.

  4. Find your vCenter and

  5. Click Edit Datasource

  6. Under Additional Information, click Enable NetFlow (or IPFIX) for the DVS.

  7. Wait a few minutes for the system to automatically fix the portgroup settings and start collecting data again.