Usage Meter fails data upload to VCF Business Console due to expired access token
search cancel

Usage Meter fails data upload to VCF Business Console due to expired access token

book

Article ID: 437955

calendar_today

Updated On:

Products

VMware Usage Meter

Issue/Introduction

VMware Cloud Director Usage Meter is unable to transmit data to the VCF Business Services Console. The notification stream fails during the authentication flow.

The dss_main.log file located at /opt/vmware/cloudusagemetering/platform/log/dss_main.log contains the following error strings:

  • Service VCF access token expire, requesting new.
  • Unexpected response body: Response{protocol=h2, code=401, message=, url=https://eapi.broadcom.com/vcf/generateToken}
  • Connectivity test failed with HTTP status 401

 

Environment

Usage Meter 9.X

Cause

Access Token is expired. 

Resolution

Resolution Steps: 

  1) Generate the Acess Token as per: Generate an Access Token in the VCF Business Services Console
  2) Update the Access Token as per: Update Access Token Details in VCF Usage Meter