Select Box Data Import Fails in Identity Manager 15.0
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Select Box Data Import Fails in Identity Manager 15.0

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Article ID: 437902

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Updated On:

Products

CA Identity Suite

Issue/Introduction

After upgrading to Identity Manager (IDM) 15.0, users may be unable to use the Select Box Data Import (XML Import File) functionality. This process, which worked in version 14.5, fails with the following error in the User Console:

The server was unable to process your request.

Error Logs
The application server logs (ims.ui) reveal a NullPointerException indicating a failure to generate or access the environment context:

java.lang.NullPointerException: Cannot invoke "Object.hashCode()" because "key" is null
java.lang.NullPointerException: Cannot invoke "com.netegrity.llsdk6.imsapi.ImsEnvironment.getImsDirectory()" because the return value of "com.netegrity.webapp.UIContext.getImsEnvironment(request)" is null

Environment

Product: Symantec Identity Manager
Version: 15.0.0-22 (Fix Pack 2 tested; likely affects all versions through FP5)
Platform: RHEL 9
Application Server: JBoss 8.1 / Wildfly

Cause

This issue is a regression in Identity Manager 15.0. The Object.hashCode() failure occurs because the environment context required for the XML import is not being generated correctly by the system in this version.

Resolution

The fix is scheduled for inclusion in Identity Suite 15.0 Fix Pack 6.

Additional Information

For the latest updates and download information, refer to the Identity Suite 15.0 Release Notes