Cluster scaleout/expansion for VCF Operations for Networks fails when initiated using VCF Operations Lifecycle GUI
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Cluster scaleout/expansion for VCF Operations for Networks fails when initiated using VCF Operations Lifecycle GUI

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Article ID: 437899

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

  • Cluster scaleout/expansion for VCF Operations for Networks fails when initiated using  VCF Operations Lifecycle GUI
  • Error message seen is as below
     
    "Error Code: LCMVRNICONFIG90083
    One or more essential services are not healthy on platform. Please use virtual machine's CLI to restart services or 'appliance-reboot' CLI to restart the VM and try creating/expanding cluster again."

Environment

VCF Operations for Networks 

Cause

Cluster scaleout/expansion for VCF Operations for Networks initiated using  VCF Operations Lifecycle GUI has a limitation as by default the  workflows deployed 2 new platform appliances with 1 TB of disc and existing platform node has 2 TB.
The CREATE CLUSTER option is enabled only when the platform is of large brick size. All platforms should be of large brick to create cluster.



    Resolution

     
    To fix this a Manual Intervention is needs to create cluster outside of VCF Operations Lifecycle GUI since brick size is XL.

    1. Create a Cluster from VCF Operations for Networks GUI.

    2. Follow instructions mentioned available at Create Clusters

    3. Cluster creation from VCF Operations for Networks GUI Takes upto 90 minutes.

    4. Once Cluster is created then login to  VCF Operations for Networks GUI to validated you see 3 Nodes on the GUI under Settings>Infrastructure and Support Infrastructure and Updates page.

    5. Now Navigate to  VCF Operations Lifecycle GUI and perform a manual Inventory sync.

      Refer to screenshot below showing option for Inventory sync