NSX Data source shows collection error "DataCollection failed due to an error. Please wait for sometime."
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NSX Data source shows collection error "DataCollection failed due to an error. Please wait for sometime."

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Article ID: 437881

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

  • NSX Data source shows collection error "Data Collection failed due to an error. Please wait for sometime."

    Refer to screenshot below:



  • On NSX UI when customer attempts  to delete the Firewall IPFIX Profile shows the following:
  • Error: Cannot delete group [/infra/domains/default/groups/All_Segments] due to following entities. These entities either lie in the group subtree or are being referred to by the group. Please delete - [[/infra/ipfix-dfw-profiles/#######-####-####-####-#########]] in order to delete the group. (Error code: 500324)

    Refer to error screenshot:

  • On NSX GUI when Navigated to Plan & troubleshoot>IPFix  section 2 profiles are created one global and another one is a manual profile. Also under collector Tab a manual profile is created as well.

    Refer to below screenshots showing manual created profiles on Firewall IPFIX Profile and Collector Tab on NSX GUI respectively.




Environment

  • VCF Operations for Networks
  • VMWare NSX

Cause

There are 2 profiles  created on NSX GUI, the one which is  manually created  profile on NSX UI is causing conflict when backend APIs are executed to fetch the flow data. This results in data collection  failed error on VCF Operations for Networks GUI.

Resolution

To fix this disable IPFIX from VCF Operations for Networks GUI and then clear the manually created profile on NSX GUI.

Steps as below:

  1. Navigate to VCF Operations for Networks GUI> Settings>Accounts and Datasource page.

  2. Edit the NSX datasource which shows the data collector failed error message.

  3. Disable DFW IPFix by unchecking the DFWIPFIX Check Box and Click Submit.

  4. Turn off data collection for the NSX datasource in question.

  5.  Login to NSX GUI and Navigate to Plan and Troubleshoot >IPFix Section

  6. Edit the manual created profile uncheck All segments. Click Save.

  7. Now Edit the profile set priority which was 0 to 1 

    Refer to screenshot below:



  8. Click save.

  9. Now it will allow to delete the manually created profile.

  10. When Profile is deleted from NSX GUI, wait for 10- 15 minutes.

  11. Make sure there is no profile on the NSX GUI.

  12. Now Navigate back to VCF Operations for Networks GUI> Settings>Accounts and Datasource page and Enabled DFWIPFIX check box and submit the datasource.

  13. On NSX GUI, now we should see only one profile on DFWIPFIX Tab and Collector Tabs and status should be Success.
    Refer to screenshots below: 





  14. Now wait for 20-30 minutes and ensure no error message should return on VCF Operations for Networks GUI under account an datasource page for the NSX Manager.

    Refer to screenshots below show shows no errors.