VCF Operations for Logs fails to import to VCF Operations fleet manager with Error Code LCMVROPSYSTEM30018.
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VCF Operations for Logs fails to import to VCF Operations fleet manager with Error Code LCMVROPSYSTEM30018.

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Article ID: 437817

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

The import of VCF Operations for Logs into the VCF Operations Fleet Manager fails, and the UI displays the following error:

Error Code: LCMVROPSYSTEM30018 java.io.IOException: Server returned HTTP response code:400 for URL: https://<VCF_Operations_FQDN>/casa/capabillties

Additionally, the /storage/log/vcops/log/casa/casa.log file contains an error indicating an invalid address format:

ERROR casa 1449 [ops@4413 threadId="568" threadName="ajp-nio-127.0.0.1-8011-exec-15" requestId="1Y0000At"] [com.vmware.ops.casa.api.ClusterDefinitionController.validateAddresses:647] - Invalid FQDN address:VCF_Operations_for_Logs_shortname

Environment

VCF Operations for logs 9.0.x
VCF Operations 9.0.x

Cause

This issue occurs because the VMware Aria Operations for Logs hostname was deployed and configured using a short name instead of a Fully Qualified Domain Name (FQDN). The internal validation requires a proper FQDN to process the import.

Resolution

To resolve this issue, update the hostname of the logging appliance to a full FQDN using one of the following methods, then retry the import.

Method 1: Update via vCenter UI (vApp Options)

  1. Log in to the vSphere Client.
  2. Locate and select the VCF Operations for Logs virtual machine.
  3. Navigate to Configure > vApp Options.
  4. Update the hostname field to reflect the full FQDN.

Method 2: Update via SSH

  1. Connect to the VCF Operations for Logs VM via SSH as root.
  2. Update the hostname by running the following command (replace <VCF-logs FQDN> with the actual FQDN):
    hostname <VCF-logs FQDN>

Final Step

After updating the hostname using either method, follow the steps below:

  1. Reboot all the nodes of VCF Operations for Logs.
  2. Navigate back to the VCF Operations > Fleet management > Lifecycle > Tasks page and retry the import task.