Settings in Node Profile are not applied as expected when saving SNMP configurations
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Settings in Node Profile are not applied as expected when saving SNMP configurations

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Article ID: 437811

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Changing the node profile settings via the GUI results in an issue where some settings are not applied.
  • Even though the syslog field is blank, the node's syslog settings are not overwritten.
  • The log for the node profile configuration change does not contain the syslog field.
YYYY-MM-DDTHH:MM:SSZ nsx-manager.corp.local NSX ##### SYSTEM [nsx@### audit="true" comp="nsx-manager" entId="00000000-0000-0000-0000-000000000001" level="INFO" reqId="#########-####-####-####-##########" subcomp="manager" update="true"] UserName="admin", ModuleName="CentralConfig", Operation="UpdateCentralNodeConfigProfile", Operation status="success", New value=["00000000-0000-0000-0000-000000000001" {"timezone":"Asia/Tokyo","ntp":{"servers":["<ntp_server_fqdn>"]},"snmp":{"v2c":{}},"resource_type":"CentralNodeConfigProfile","id":"00000000-0000-0000-0000-000000000001","display_name":"All NSX Nodes", "description":"All configurations in this profile are applied to Manager and Edge nodes.","_system_owned":false,"_protection":"UNKNOWN","_revision":9}]

Environment

VMware NSX : 4.x

Cause

Various configurations are expected to be updated according to the node profile values.

Changing the SNMP settings via the GUI causes the syslog field to be deleted, preventing the overwrite from occurring.

Resolution

This issue has been resolved in version 4.2.1, where the syslog field is no longer deleted.

The steps for syslog are as follows:

  1. Navigate to System > Fabric > Profiles > Node Profiles.
  2. Select "All NSX Nodes".
  3. Click "EDIT" in the "Summary" section.
  4. Click "SAVE" without making any changes.

To verify if the workaround is functioning correctly, please execute the following command:

grep -a "UpdateCentralNodeConfigProfile" /var/log/syslog |tail -n 1

You will verify that the "syslog" field exists as shown in the following output example.

YYYY-MM-DDTHH:MM:SSZ nsx-manager.corp.local NSX ##### SYSTEM [nsx@### audit="true" comp="nsx-manager" entId="00000000-0000-0000-0000-000000000001" level="INFO" reqId="#########-####-####-####-##########" subcomp="manager" update="true"] UserName="admin", ModuleName="CentralConfig", Operation="UpdateCentralNodeConfigProfile", Operation status="success", New value=["00000000-0000-0000-0000-000000000001" {"timezone":"Asia/Tokyo","ntp":{"servers":["<ntp_server_fqdn>"]},"syslog":{},"snmp":{"v2c":{}},"resource_type":"CentralNodeConfigProfile","id":"00000000-0000-0000-0000-000000000001","display_name":"All NSX Nodes", "description":"All configurations in this profile are applied to Manager and Edge nodes.","_system_owned":false,"_protection":"UNKNOWN","_revision":9}]