ESX hosts enter "Not Responding" state in vCenter UI after changing the network uplink speed
search cancel

ESX hosts enter "Not Responding" state in vCenter UI after changing the network uplink speed

book

Article ID: 437712

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • You are changing the speed of the switch interface connected to the only available vmnic uplink on a host's virtual switch.
  • After making this change, the host enters a "Not Responding" state in vCenter UI.
  • The host state in vCenter will recover on its own after an extended period of time (i.e. 30 minutes).
  • The host management IP stops responding to ICMP request and other network traffic during this period

Environment

VMware ESXi 8.x

Cause

This occurs because the speed change requires the host vmnic to be bounced (go down and then up). Since the vmnic being downed is the only available uplink, the host has no failover option, and therefore must "fallback" to the down vmnic.  However, the ESX Advanced Setting "TeamPolicyUpDelay" has been configured for a long time frame (1800000 ms / 30 minutes). This instructs the host to wait 30 minutes to fallback to the available uplink.

Resolution

To prevent this issue during the configuration change, perform one of the following two options:

  • Add an additional uplink to the virtual switch so the host can fail over to an available uplink when the altered vmnic is administratively down
  • Remove/reduce the configured delay in the advanced setting TeamPolicyUpDelay at least temporarily while the speed configuration is changed to allow the host to fallback to the same uplink that bounced. 

Additional Information

See Using the TeamPolicyUpDelay setting for details on this advanced setting.