Unable to expand VMFS datastore from the vSphere client
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Unable to expand VMFS datastore from the vSphere client

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Article ID: 437693

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • Following the expansion of the underlying LUN for a VMFS datastore, the Increase Datastore Capacity wizard may fail to populate the storage device as an available resource for expansion under Datastore > Increase datastore capacity.

 

  • The datastore may be presented to multiple ESXi hosts within or across several clusters.

Environment

VMware vSphere ESXi 8.x

VMware vSphere ESXi 9.x

Cause

 This issue will arise if there is a LUN ID mismatch for the same datastore across the ESXi hosts within or across the cluster where the LUN is mounted.

 

Resolution

Engage storage vendor to ensure the LUN ID is consistent across all ESXi hosts where the datastore is presented. The LUN must be mapped using the same LUN ID from the storage array side to all ESXi hosts.

  • Determine which LUN ID is used by the majority of the cluster or according to your storage policies.
  • Power off  or migrate any virtual machine accessing the problematic LUN/RDM.
  • Unmount the VMFS LUN from the affected ESXi hosts.
  • Correct mapping from Storage array Side > Unmap the LUN from affected hosts and remap it using the correct ID that matches the cluster.
  • In vCenter, navigate to affected ESXi host cluster and rescan storage from the cluster level to sync the LUN ID across cluster.
  • Mount back the datastore and rescan the storage once again.