LDAP Configuration of NSX manager fails with error "The Hostname Of the LDAP Server Could Not Be Resolved"
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LDAP Configuration of NSX manager fails with error "The Hostname Of the LDAP Server Could Not Be Resolved"

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Article ID: 437625

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The Connection Status of LDAP server at User Management > Authentication Providers > LDAP  shows "Failed".
  • When you scroll over the mouse on it, you'd see an error message - "The hostname of the LDAP server could not be resolved"
  • Below logs will be logged in /var/log/proxy/reverse-proxy.log
    yyyy-mm-ddThh:mm:ss.zzz [NSX-Manager-FQDN] NSX ### SYSTEM [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="manager"] An error occurred while searching LDAP Identity Source [LDAP server DNS Name]

 

Environment

VMware NSX

Cause

The issue is caused by the NSX Manager being unable to resolve the LDAP server’s DNS name to its IP address.

Resolution

  • To resolve the issue, verify that the LDAP server’s DNS name is correctly mapped to its IP address on the DNS server.
  • As a workaround, edit the host file (/etc/hosts) on the NSX Manager to manually map the LDAP server’s DNS name to its IP address.