Error "Failed - Reason: Failed to upload file" when using Log Assist to upload support bundle
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Error "Failed - Reason: Failed to upload file" when using Log Assist to upload support bundle

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Article ID: 437604

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Updated On:

Products

VCF Operations

Issue/Introduction

  • Attempting to upload a support bundle using Log Assist results in Failed status.
  • "Reason: Failed to upload file. For troubleshooting steps, see KB Article 375818"
  • None of the Causes in KB 375818 match the failure in this scenario
  • The Fleet Manager logs were successfully received by Broadcom, but the VCF Operations support bundle failed.
  • Retrying the Log Assist upload resulted in the same error.

Environment

VCF Operations 9.0.x

Cause

Problems chunking the support bundle for upload. Review the docker container logs for errors like:

org.apache.http.ConnectionClosedException: Premature end of chunk coded message body: closing chunk expected

To review the log-assist docker container logs:

  1. Log in to the cloud proxy as root via SSH or vSphere console
  2. Run the command
    docker logs log-assist

Resolution

Reboot the cloud proxy appliance VM and try the Log Assist upload again.

Additional Information

Diagnostics for VMware Cloud Foundation: Diagnostics Log Assist Connectivity