License within VVF or VCF environment show as expiring earlier than expected.
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License within VVF or VCF environment show as expiring earlier than expected.

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Article ID: 437580

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When viewing licensing information in a 9.x VVF (VMware vSphere Foundation) or VCF (VMware Cloud Foundation) environment, the expiration date is earlier than your contracted license date.
  • Within vCenter in a VVF environment you will see "Expiration Date" of 6 months after the last license update/install. 
  • Error within vCenter Client of: "You have expired or expiring version 9+ licenses in your inventory" and your expiration date for that license is 6 months after the license was installed.

Environment

  • VMware vSphere Foundation (VVF) 9.x
  • VMware Cloud Foundation (VCF) 9.x

Cause

This is by design.

Licenses must be updated every 6 months to maintain licensing.

As per Update Licenses in Connected Mode, "You must still update your licenses in the VCF Operations instance at least once every 180 days to verify that the usage file has been submitted correctly and to keep your environment licensed."

Resolution

You must update your licenses at least once every 6 months (180 days). If license usage data is not submitted within the required reporting time-frame, and you do not update your licenses, your licenses are treated as expired, your hosts are disconnected from the vCenter instance, and you cannot start any workload operations. You can also update your licenses at any time to extend your usage reporting refresh period.

  1. In the VCF Operations instance, navigate to License Management > Registration.
  2. To verify that your license usage file was submitted within the last 24 hours, check the Last Usage Report Generated date.
  3. Click Update Licenses.

Your VCF Operations instance is updated with the latest license information available from the VCF Business Services console.