EEM Server installation fails with CA Directory Configuration error
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EEM Server installation fails with CA Directory Configuration error

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Article ID: 437571

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog CA Service Desk Manager

Issue/Introduction

When installing EEM in secondary server, it fails in the UI with the following error:

CA Directory Configuration failed

The %TEMP%/eiam-install.log shows the following error:

ConfigureCADirectoryAction - CA Directory configuration failed
java.io.IOException: Command [dxnewdb itechpoz] failed with error code [2]

Environment

Windows Server

EEM 12.6.x and later

Cause

Permission issues causing this issue to occur

Resolution

1. Remove the Directory folder created from the failed attempt (ie: C:\Program Files\CA\Directory)

2. Go to the properties of the destination folder (ie: C:\Program Files\CA) | Security tab | Add Full control privileges to the username being used to install EEM

3. Disable AV and similar tools that could block the installer.

4. Run the EEM installer.

Additional Information

CA Embedded Entitlements Manager installation fails during CA Directory installation and configuration phase