Intermittent RDP connection failures when going through ZTNA segment application
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Intermittent RDP connection failures when going through ZTNA segment application

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Article ID: 437503

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Updated On:

Products

Symantec ZTNA

Issue/Introduction

  • Users experience failures when attempting to establish an RDP connection via ZTNA segment application.
  • Connections often succeed only after several consecutive attempts.
  • In some instances, the connection drops even after the Windows credentials prompt is displayed.

Environment

  • Symantec ZTNA

Cause

RDP usually uses multiple TCP sessions to establish connection.

When using multiple ZTNA connectors, sessions will be load balanced to different connector.

This causes the session state to be lost, resulting in the connection being reset by the backend or the connector.

Resolution

Enable Session Stickiness (also known as session persistence) on the load balancer or ZTNA site configuration.

This ensures that all packets for a specific RDP session are consistently routed to the same ZTNA connector for the duration of the connection attempt and session.