Error: "Could not find SSL/X509 certificate" error encountered on the service endpoint in VMware Cloud Director Availability 4.x
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Error: "Could not find SSL/X509 certificate" error encountered on the service endpoint in VMware Cloud Director Availability 4.x

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Article ID: 437502

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • While editing/reconfiguring the VMware Cloud Director (VCD) service endpoint from VMware Cloud Director Availability (VCDA), the operation fails with the following error: “Could not find SSL/X509 certificate from ‘https://<VCD_FQDN>/api’.”
  • The same error may appear in the VCDA Provider Portal → System Health section.
  • Validating the connectivity using "openssl s_client -connect VCD_FQDN:443"  fails with connection refused error:


  • Running the df -h command on the VCD cells shows that the root (/) is at or near 100% full.
  • VCD cells shows "Inactive" in the VCD provider portal.

Environment

VMware Cloud Director 10.x
VMware Cloud Director Availability 4.7.x

Cause

Disk space exhaustion on the root partition causes the VCD service to fail and become inactive, which prevents VCDA from successfully retrieving the required SSL/X509 certificate during the site pairing process.

Resolution

  1. Establish an SSH connection to the affected VCD cell.
  2. Reclaim space from the root partition by following the appropriate storage remediation guidelines mentioned in the KB: cloud-director-cell-partition-full
  3. Restart the VCD service by executing the following commands:
    service vmware-vcd stop

    service vmware-vcd start