Unable to remove a stale datastore entry from vCenter inventory
search cancel

Unable to remove a stale datastore entry from vCenter inventory

book

Article ID: 437470

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

  • Unable to remove or delete a datastore from vCenter inventory.

  • Datastore displays "Inaccessible" status in the vSphere Client.
  • No active host connections to the datastore.

  • The device backing details for the datastore does not display any information.

  • "Delete Datastore" option is grayed out.

  • Error message: "Datastore <datastore_name> is not accessible. No connected and accessible host is attached to this datastore" when attempting to browse or remove the datastore.

Environment

  • vCenter 9.x
  • vCenter 8.x
  • ESX 9.x
  • ESXi 8.x

Cause

This issue occurs when a datastore is improperly removed by revoking host access directly at the storage array level without first following the correct unmount and detach procedures in vSphere. Consequently, a stale datastore object is orphaned within the vCenter Server inventory, rendering it difficult to remove.

Resolution

NOTE: Always follow the correct procedure to unmount a datastore from vCenter or ESXi to avoid such issues by following KB: Detach a LUN device from ESXi hosts

Follow the below steps to remove the stale datastore:

  1. Perform a Cluster-Level Rescan:

    1. Log in to the vSphere Client.
    2. Select the cluster or host.
    3. Navigate to Configure > Storage > Storage Adapters.
    4. Click Rescan and select "Scan for new storage devices."

  2. Reboot Associated ESXi Hosts:

    1. If the datastore persists, reboot all ESXi hosts that were previously connected to this datastore.
    2. This forces an inventory refresh and allows the host agent (hostd) to report the missing device state to vCenter Server.

  3. Manual Database Cleanup:

    1. If the above step does not work, the datastore must be removed from the vCenter Database manually. Refer KB: Unable to remove a datastore from the vCenter Server inventory
    2. For further assistance, open a Broadcom support case. Refer KB: Creating and managing Broadcom cases