Unable to remove or delete a datastore from vCenter inventory.
No active host connections to the datastore.
The device backing details for the datastore does not display any information.
"Delete Datastore" option is grayed out.
Error message: "Datastore <datastore_name> is not accessible. No connected and accessible host is attached to this datastore" when attempting to browse or remove the datastore.
This issue occurs when a datastore is improperly removed by revoking host access directly at the storage array level without first following the correct unmount and detach procedures in vSphere. Consequently, a stale datastore object is orphaned within the vCenter Server inventory, rendering it difficult to remove.
NOTE: Always follow the correct procedure to unmount a datastore from vCenter or ESXi to avoid such issues by following KB: Detach a LUN device from ESXi hosts
Follow the below steps to remove the stale datastore: