We are receiving session timeouts in NCM using NCM Webapp, even though the session is active
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We are receiving session timeouts in NCM using NCM Webapp, even though the session is active

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Article ID: 437405

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

After upgrading to NCM 25.4.5 we have noticed several different occurrences for different users, that while their session was active, they would be automatically logged out and would have to login back again.

Environment

NCM 25.4.5

NCM Webapp (Browser Client)

Cause

The root cause appears to be that the server-side keep-alive mechanism only refreshes one of the multiple authentication cache entries created during a Webswing login, allowing the remaining entries to expire and trigger a forced logout. 

Resolution

This will be fixed in a future NCM release.

Additional Information

This can be tracked in issues resolved under DE183992