Inventory search not working.
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Inventory search not working.

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Article ID: 437400

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Updated On:

Products

DX Operational Intelligence

Issue/Introduction

We are trying to fetch the device inventory details from OI using REST API. They are successful in fetching data for the devices with the following sources UIM,SPECTRUM, CAPM but other sources such as SCOM, Dynatrace, Atrium etc., are not returning any values.

Using /oi/v2/api/maintenance/inventory/_search API to search for inventory item data in order to create a maintenance schedule in an automated fashion.

Environment

DX O2 On premise 25.1

Cause

This is indeed a bug in the API as it applies to any "CUSTOM" data source, any non-Broadcom product.

Resolution

It is a confirmed bug that is being worked to be fixed on the 26.1 on-premise release.
For now, we do not have an estimated time to deliver it, If you need, please raise a ticket on Broadcom Support Portal and ask for the update on this.