Understanding "Edge node status changed: Up (Routing Down) -> Up" INFO logs in NSX
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Understanding "Edge node status changed: Up (Routing Down) -> Up" INFO logs in NSX

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Article ID: 437333

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Updated On:

Products

VMware NSX

Issue/Introduction

Administrators may observe specific INFO-level log entries regarding Edge node status changes within their NSX environment. Specifically, the edge's syslog generates logs containing the vmwNSXClusterNodeStatus event ID, similar to the following example:

 

[nsx@6876 comp="nsx-edge" subcomp="nsxa" s2comp="ha-cluster" level="INFO" eventId="vmwNSXClusterNodeStatus"] {"event_state":2,"event_external_reason":"Edge node status changed: Up (Routing Down) -> Up "}

 

This article provides a technical breakdown of these log entries and clarifies their impact on the environment.

Environment

VMware NSX 4.x

Cause

  • These log entries are expected behavior and do not indicate a functional issue, routing failure, or system outage.
  • The generation of these logs is due to the following internal mechanisms:
  • Legacy Alarm Clearing Mechanism: These specific log entries are a component of the legacy NSX alarm and event framework. The INFO severity level indicates that the event is acting as a clearing mechanism to reset a previous alarm state (such as an old "Routing Down" alert), should one have existed.
  • Internal Trigger Conditions: The event is triggered internally whenever an update is made to the host-config. In the NSX architecture, a host-config update automatically occurs any time an Edge node reconnects or synchronizes with the Management Plane (MP). This sync and subsequent log generation will occur even if an administrator has not made any active configuration changes.

Resolution

No administrative action is required to resolve this. Seeing these status messages is by design; when the Edge synchronizes with the Management Plane, the system logs this event to successfully clear out any stale "Routing Down" alarms. Its is safe to ignore these messages.

Additional Information

The legacy alarm framework responsible for generating these specific messages has been completely removed in VMware Cloud Foundation (VCF) 9.0 and later versions. You will no longer observe this specific logging behavior once the environment is upgraded to VCF 9.0 or onward.