Failed to create new Active Directory (AD) account when it has special characters in its name.
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Failed to create new Active Directory (AD) account when it has special characters in its name.

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Article ID: 43730

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

While trying to create a new Active Directory account (ADS) which has special characters you receive a message in View Submitted Tasks (VST) or in etatrans log file. Searching in ADS we found several accounts with special characters

"msg: :ETA_E_0016<AAC>, Account for Global User 'XXXXXX' on Active Directory Endpoint 'YYYYY' creation failed: :ETA_E_0004<AAC>, Active Dir. Account 'Test Production' on 'YYYYY' creation failed: The value 'Test Production' for attribute 'Display Nickname ASCII only (Exchange2000 only)' is not ASCII"

Environment

CA Identity Manager 14.x

Cause

This is a limitation with this Exchange field "Simple Display Name" which does not allow non ASCII characters

Resolution

To resolve this problem in CA Identity Manager you must remove the Rule String from AD Template, "Exchange Advanced" tab, or change the Rule String for another that does not retrieve a value with a special character.

 

Below are two images from this field in Provisioning Manager and CA IdM UI.