Content Library Advanced Configuration tab appears blank
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Content Library Advanced Configuration tab appears blank

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Article ID: 437236

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When logged into the vSphere Client with a user account assigned the Administrator role at the Global Permission level, the Advanced Configuration tab under Content Library appears blank.

Environment

VMware vCenter Server 8.0.x

Cause

Beginning with vCenter Server 8.0, SSO permissions for the default Administrator role have been restricted to enhance security.

Resolution

To grant a custom user or Active Directory (AD) user access to the Content Library Advanced Configuration view, perform one of the following options:

Option 1: Add the user to the SSO Administrators Group

  1. Log in to the vSphere Client as [email protected].
  2. Navigate to Administration > Single Sign-On > Users and Groups.
  3. Select the Groups tab.
  4. Locate and click on the Administrators group.
  5. Click Add Members, search for the desired user, and click Save.

Option 2: Assign specific management group memberships

If the user should not be a full SSO Administrator, add them to the following specific groups:

  1. Navigate to Administration > Single Sign-On > Users and Groups > Groups.
  2. Add the user to the CAAdmins group.
  3. Add the user to the SystemConfiguration.Administrators group.

Note: It is recommended to add Active Directory users to the SystemConfiguration.Administrators group only for the duration of the configuration task and to remove them afterward to maintain a secure environment.