CA API Gateway metrics stopped reporting to APM 10.8
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CA API Gateway metrics stopped reporting to APM 10.8

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Article ID: 437224

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Updated On:

Products

DX Application Performance Management

Issue/Introduction

In API Gateway logs, we can see the below error

cd /opt/SecureSpan/Gateway/node/default/var/logs/ssg_0_0.log

WARNING 4042: Problem routing to http://localhost:9080/apm/metricFeed. Error msg: Unable to obtain HTTP response from http://localhost:9080/apm/metricFeed: Connection to http://localhost:9080 refused. Caused by: Connection refused
WARNING 2520: Error in Send Metrics to APM scheduled task policy execution: Error in Assertion Processing

Environment

  • DX APM 10.8.*
  • Layer7 API
  • CA Precision API Monitoring

Cause

APM Agent is not running

Resolution

  1. Ensure APM InfraAgent is up and running. For more information, refer to the APM official documentation

    ./APMIACtrl.sh start
  2. Ensure you are using a supported configuration in Layer7, PAPIM and APM Agent side, refer to Layer7 matrix and APM matrix

  3. Ensure APM IA ports are configured correctly and ports available to communicate with API Gateway

a) In Agent side:

Open the apmia\core\config\IntroscopeAgent.profile file.
Verify

introscope.epagent.config.networkDataPort=9090 (apm.epagent.tcpport in API Gateway)
introscope.epagent.config.httpServerPort=9080 (apm.epagent.httpport)

refer to the official APM documentation

b) In Gateway side

Here is an example, refer to the official PAPIM documentation.