Tasks stuck in "Waiting for Rollback" when using PreDefined Breakpoints in JOBP
search cancel

Tasks stuck in "Waiting for Rollback" when using PreDefined Breakpoints in JOBP

book

Article ID: 437171

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

The Automation Engine fails to correctly transition task statuses during a rollback operation when triggered by a predefined breakpoint condition within the Workflow logic.

Symptoms

When attempting to use the 'Rollback to this Task' functionality in a Workflow, users may experience the following:

  • All tasks in the workflow remain stuck in the status 'Waiting for Rollback'
  • The rollback fails to progress even when predecessors have finished
  • This specifically occurs when the workflow is blocked by a 'Breakpoint' that was predefined in the JOBP object definition
  • The issue does not occur if the Breakpoint was set manually in the Workflow Monitor or if the task ended in a failed status (e.g., ENDED_NOT_OK)

 

Cause

This is a product defect with reference DE177678

Resolution

Solution:

Update to a fix version listed below or a newer version if available.


Fix version:

Component(s): Automation Engine

Automation.Engine 26.1.0 - TBD

Additional Information

Public description: A problem has been fixed where the functionality 'Rollback to this Task' was not working as expected.