VMware Aria Suite Lifecycle Patch 7 Update Fails: UI Stuck at “Waiting for services to start”
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VMware Aria Suite Lifecycle Patch 7 Update Fails: UI Stuck at “Waiting for services to start”

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Article ID: 437148

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Updating VMware Aria Suite Lifecycle to Patch 7 fails with "UI stuck at restarting vRSLCM services".

  • Reviewing the patchcli.log indicates that patch installation completed.

  • Reviewing the os-package-update.log reveals the following error message:

    • Finding packages in the target repo. This may take several minutes.
      <YYYY-MM-DD>T<HH:MM:SS>+00:00 Error: Packages - tcpdump - are not available in the target repo for OS upgrade. Please provide the correct repo having the required packages.
      Original list of RPMs and RPM DB are stored in /tmp/photon-upgrade-<random_string>,  please provide contents of that folder along with system journal   logs for analysis; these logs can be captured using command-
       # /usr/bin/journalctl -xa > /tmp/photon-upgrade-<random_string>/journal.log
       Cannot continue. Aborting.

Environment

VMware Aria Suite Lifecycle 8.18.x

Cause

The issue occurs because a manually installed tcpdump package is not identified as a supported component during the Patch 7 update of VMware Aria Suite Lifecycle.

Resolution

To resolve this issue, follow the below steps:

Step 1: Take a Snapshot

Before making any changes, take snapshot for vRSLCM appliance in vCenter.

Step 2: Remove the tcpdump Package

  1. Log in to the vRSLCM appliance via SSH using the root account.

  2. Execute the following command to remove the package:

    tdnf remove tcpdump
    
  3. Verify that the package has been successfully removed by running:

    rpm -qa | grep tcpdump
    

    (This command should return no output, confirming the removal).

Step 3: Re-initiate the patch

  1. Log back into the Aria Suite Lifecycle (vRSLCM) UI.

  2. Navigate to the patching section and attempt the Patch 7 installation again. The patch should now proceed successfully.

Once the "tcpdump" package is removed, retry the patch using KB-CSP-102547 Patch Instructions for VMware Identity Manager 3.3.7 and VMware Aria Suite Lifecycle 8.18.0 Patch 6 and 7: