ゲスト OS のカスタマイズが次のエラーで失敗する:「[SC] EnumQueryServicesStatus:OpenService FAILED 1060:」
search cancel

ゲスト OS のカスタマイズが次のエラーで失敗する:「[SC] EnumQueryServicesStatus:OpenService FAILED 1060:」

book

Article ID: 437045

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

免責事項: これは英文の記事「Guest OS Customization failing with the following error "[SC] EnumQueryServicesStatus:OpenService FAILED 1060:"」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

新しく作成したテンプレートを使用すると、次のエラーが発生してゲスト OS のカスタマイズが失敗します。

guestcust.log に次のエラーが表示されます。

[YYYY-MM-DDTHH:MM:SS:                 GuestCustUtil:  DEBUG] Status marker file C:/WINDOWS/.post-gc-status doesn't exist
[YYYY-MM-DDTHH:MM:SS:     WindowsOsAbstractionLayer:   INFO] Executing command: 'C:\WINDOWS\system32\sc.exe query "VMware Guest OS Customization Task" '
[YYYY-MM-DDTHH:MM:SS:     WindowsOsAbstractionLayer:   WARN] Command execution failed with exit code: 1060, output: '[SC] EnumQueryServicesStatus:OpenService FAILED 1060:
The specified service does not exist as an installed service.

Environment

VMware ESXi 8.x

Cause

これは guestcust で一般的に発生し得るエラーです。サービスは「VMware Guest OS Customization Task」が実行されているか確認しており、実行されていないため、削除する必要はありません。

[YYYY-MM-DDTHH:MM:SS:                 GuestCustUtil:   INFO] Task 'VMware Guest OS Customization Task' exists and will be deleted: false

 

以下のログから sysprep の更新が開始されていることがわかります。これは、ゲスト OS のカスタマイズが完了し、プロセスが sysprep に引き継がれていることを意味します。

[YYYY-MM-DDTHH:MM:SS:                 GuestCustUtil:  DEBUG] Creating sysprep copy in dir:'C:\sysprep1008'`  
[YYYY-MM-DDTHH:MM:SS:                 GuestCustUtil:   INFO] Copying C:\sysprep to C:\sysprep1008.`  
[YYYY-MM-DDTHH:MM:SS:                              :  DEBUG] Copying file/directory from 'C:\sysprep' to 'C:\sysprep1008'`  
[YYYY-MM-DDTHH:MM:SS:                 GuestCustUtil:  DEBUG] Schedule command: 'C:\sysprep1008\guestcustutil.exe post-run HandleCustomizationCompleted<\|/>'`

Resolution

「VMware Guest OS Customization Task」サービスが存在しないこと (エラー 1060) は想定された動作であり、カスタマイズの成功には影響しません。
使用するすべての sysprep ツールとイメージングツールが、ターゲットの Windows バージョン (Windows Server 2022 や Windows 11 など) と互換性があることを確認してください。
さらにトラブルシューティングを行うには、setupact.log と setuperr.log を確認して WinRE 関連の追加エラーがないか調べ、サードパーティ製ソフトウェアが OOBE プロセスに干渉していないことを確認してください。

WinReOobeInstall WinRE install succeeded

sysprep で発生する問題のトラブルシューティングについては、Microsoft サポートにお問い合わせください。