VM's including vCenter VM running on vSAN OSA Storage have become inaccessible
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VM's including vCenter VM running on vSAN OSA Storage have become inaccessible

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Article ID: 436946

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Updated On:

Products

VMware vSAN

Issue/Introduction

When starting any of the inaccessible VMs, the error "can't enumerate all disks" is displayed. However, disk are visible in the vSAN datastore

Environment

vSAN OSA 8.0u3x

Cause

localcli vsan debug object list -u on the device shows, the disk is part of a RAID 5, which can tolerate 2 faults.

However the results show three faults, which means data loss has occurred, and should be restored from backup. 

If no backups are available, and engagement with the hardware vendor is required to recovered the VM's.  

RAID_5
         Component: XXXXXX-XXXX-XXXX-XXXX-XXXXXXXX
           Component State: ABSENT,  Address Space(B): 5368709120 (5.00GB),  Disk UUID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX,  Disk Name: N/A
           Votes: 1,  Host UUID: None
         RAID_1
            Component: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX
              Component State: ABSENT,  CSN: STALE (1220!=1715),  Address Space(B): 5368709120 (5.00GB),  Disk UUID: XXXXXXX-XXXX-XXXX-XXXXX-XXXXXX,  Disk Name: N/A,  Transient: 1
              Votes: 1,  Host UUID: None
            Component: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX
              Component State: RECONFIGURING,  Address Space(B): 5368709120 (5.00GB),  Disk UUID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX,  Disk Name: naa.XXXXXXXXXXXXX:2
              Votes: 1,  Capacity Used(B): 281018368 (0.26GB),  Physical Capacity Used(B): 4194304 (0.00GB),  Total 4K Blocks Used(B): 4194304 (0.00GB),  Host Name: ESXi.example.com
         Component: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX

Resolution

Engage with the hardware vendor to recovered or recreate the inaccessible VM's.

Additional Information

from hostd.logs we also see repeated Input/output error (5) which indicate accessibility problems with the disk object

2026-04-09T10:30:18.666Z In(166) Hostd[2331948]: [Originator@6876 sub=Libs opID=esxui-XXXX-XXXX sid=XXXX user=root] SNAPSHOT: SnapshotDiskTreeAddDiskHierarchy: Couldn't add disk '/vmfs/volumes/vsan:XXXXXXXX-XXXXXXXXXXX/XXXXXXX-XXXX-XXXX-XXXX-XXXXXXXX/VMware vCenter Server_6.vmdk': Input/output error (5).

If the issue is caused by a VM showing 0 MB or if there is a lock on the VM, that can be resolved by following:

knowledge base article: 418516