SslConfig Fails to Stop Processes with Process has failed to stop Errors
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SslConfig Fails to Stop Processes with Process has failed to stop Errors

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Article ID: 436936

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

When running the SslConfig utility on the DX NetOps Portal server to perform operations such as 5: Import updated Portal signed certificate, the utility fails during the service shutdown phase. The following error messages appear in the terminal:

  • Waiting for caperfcenter_sso to stop... Process has failed to stop
  • Waiting for caperfcenter_console to stop... Process has failed to stop
  • Waiting for caperfcenter_devicemanager to stop... Process has failed to stop
  • Waiting for caperfcenter_eventmanager to stop... Process has failed to stop

Cause

The user being used to run SslConfig does not have the capability to run the systemctl commands necessary to restart services

Resolution

To resolve this issue, the SslConfig utility must be executed with elevated privileges. Follow these steps:

  1. Log in to the DX NetOps Portal server terminal as a user with sudo access.
  2. Navigate to the tools directory:

    cd /opt/CA/PerformanceCenter/Tools/bin
  3. Execute the SslConfig utility using sudo:

    sudo ./SslConfig
  4. Proceed with Option 5: Import updated Portal signed certificate or your intended configuration.

Verify that the utility successfully stops the processes, as indicated by the following log entry: Waiting for caperfcenter_sso to stop... Process has stopped successfully