Stale Supervisor servers still present in VCF Automation 9 Region after being removed from vCenter
search cancel

Stale Supervisor servers still present in VCF Automation 9 Region after being removed from vCenter

book

Article ID: 436875

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

The Supervisor was removed from vCenter, but the VCF Automation 9.0 did not clear it out of the Region it was associated with.

Log into the VCF Automation and under Infrastructure select Regions.  In the Supervisors column of the Region may contain an old Supervisor name, or may display an extra comma indicating there should be something displayed previous to the comma.

Edit the Region and check the Supervisors selection box. At the bottom of the box it should indicate the number of Supervisors next to a check box on the left, and on the right it will say "# - # of # Supervisors" indicating the number of Supervisors it knows of.  If the number is larger than the number of displayed Supervisors available to select there is a stale entry.

Environment

VCF Automation 9.0

Cause

A Supervisor server was removed from the vCenter environment, but the VCF Automation Region still has a record of it that didn't get cleaned up.

Resolution

  • Delete the region that points to stale supervisor. Refresh VC and recreate a new region with new supervisor.

  • If the region cannot be deleted, open a Support Request with Broadcom Technical Support and note this Article ID (436875) in the problem description. For more information, see Creating and managing Broadcom support cases.

Additional Information

Issue is expected to be resolved in the 9.1 release of VCF where user can edit the region to remove stale supervisor and add new one.