Error: "Connection to Veeam Backup Infrastructure failed. Please contact your service provider" while loading the Veeam plugin in VMware Cloud Director
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Error: "Connection to Veeam Backup Infrastructure failed. Please contact your service provider" while loading the Veeam plugin in VMware Cloud Director

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Article ID: 436791

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • The Veeam plugin fails to load in the VMware Cloud Director with below error,
    Connection to Veeam Backup Infrastructure failed. Please contact your service provider.
  • Veeam Manager and backup servers are running correctly, and backup jobs are functional.
  • Browser Developer Tools (Network tab) show a 500 Internal Server Error when attempting to load the plugin.
  • Testing the SSL handshake from the VCD primary cell using: openssl s_client -showcerts -connect <veeam_url>:9443 returns the error: unable to verify the first certificate.

Environment

VMware Cloud Director 10.6.x

Cause

The SSL handshake between VMware Cloud Director and the Veeam Backup Enterprise Manager is failing because the Veeam server's SSL certificate is not present or trusted within the VCD Trusted Certificates store.

Resolution

To resolve the issue:

  1. Obtain the current SSL certificate used by the Veeam Backup Enterprise Manager.
  2. Log in to the VCD Provider Portal as a System Administrator.
  3. Navigate to Administration > Certificate Management > Trusted Certificates.
  4. Click Import and upload the Veeam SSL certificate. 
  5. Test remote connection. 
    You can refer the document : Import Trusted Certificates Using Your VMware Cloud Director Service Provider Admin PortalVMware Cloud Director Tenant Portal
  6. Verify SSL Handshake by running the below handshake test from the VCD cell and confirm the successful connection.
    openssl s_client -showcerts -connect <veeam_url>:9443