UIM QoS Queue is Down.
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UIM QoS Queue is Down.

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Article ID: 436696

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) DX Operational Observability

Issue/Introduction

Repeated alarms being generated by the oi_connector probe about its Qos queue.

Environment

  • oi_connector 2.01 or higher

  • DX UIM 23.4x

Cause

  • low setting of parameter

Resolution

uim_queue_monitor_interval_seconds

  • This is a parameter in the oi_connector probe. By default this is set to 5 (seconds) which generates an alarm quite frequently even for small inconsequential events when the queue loses its subscription.

  • Set this higher than 5 seconds which is aggressive and somewhat misleading in a large environment. Try 30 or 60 seconds so you don't generate any false alarms if whatever is slowing the queue down or interfering with the subscription is quickly remedied.


Other oi_connector alarm options

axagateway_alarm_severity

  • You can set the value of this key to define the severity of the alarm that is generated by the oi_connector probe. For example, 

  • “UIM QoS Queue is Down.” The default severity is 5 (Critical).


generate_uim_queue_down_alarm

  • You can set the value of this key to enable or disable the alarm that is generated by the probe when a queue is down. The default is True.

  • If the value is set as false, then no queue down alarm is generated.

Additional Information

generate_doi_monitoring _down_alarm

  • You can set the value of this key to enable or disable the alarm that is generated by the probe when DX Operational Observability (DX Operational Observability or tenant) is not available. Default value is true.