Server or Agent not reachable in NAC console
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Server or Agent not reachable in NAC console

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Article ID: 436684

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

A Server (NES) and/or an agent appears as reachable = No in Nolio UI.
The server and agents are up and running and there are no network connectivity issue between the agent/server and NAC

Environment

Release Automation - All Version

Cause

This problem could be caused by a blocked thread "connectivityInboundAdapter.container-*" on NAC

Example :
- On NAC open the JMX page http://<NAC_SERVER>:20203/mbean?objectname=noliocenter%3Atype%3Dinfo
Default user/password is nolio/nolio

- Invoke the function makeThreadDump

- This generates a page with the list of all threads.

- Search the string "BLOCKED on"

If a thread "connectivityInboundAdapter.container-*" could be found, apply the solution below :

Example

"connectivityInboundAdapter.container-1" Id=<ID> BLOCKED on com.nolio.platform.server.integration.jms.components.nac.NesConnectionEnsurerServiceImpl@<id> owned by "ExecutionServerStatusTask-*" Id=<ID>
at com.nolio.platform.server.integration.jms.components.nac.NesConnectionEnsurerServiceImpl.ensureNesInfoAndBrokerConnection(NesConnectionEnsurerServiceImpl.java:84)
-  blocked on com.nolio.platform.server.integration.jms.components.nac.NesConnectionEnsurerServiceImpl@<id>
at sun.reflect.GeneratedMethodAccessor700.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)

 

Resolution

Restart the Service "Nolio Release Automation Service" on the NAC server.