VMware Identity Manager is showing a RED health status in VMware Aria Suite Lifecycle, even though the System Diagnostics dashboard reports its health as GREEN
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VMware Identity Manager is showing a RED health status in VMware Aria Suite Lifecycle, even though the System Diagnostics dashboard reports its health as GREEN

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Article ID: 436622

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • You observe that the VMware Identity Manager health status is reported as RED in VMware Aria Suite Lifecycle.

  • When you navigate in the UI to Lifecycle operations > Environment > Global environment > View details > (...) > Remediate cluster, the VMware Identity Manager postgres cluster health page pops up and displays a stale IP address.



  • Additionally, you notice the following behaviors:

    • All VMware Identity Manager nodes show an UP status.

    • The VMware Identity Manager system diagnostic dashboard displays the health status as Green.

    • The inventory sync of VMware Identity Manager completes successfully in VMware Aria Suite Lifecycle.

    • Despite the successful sync, the health status does not change to Green in the VMware Aria Suite Lifecycle UI.

Environment

VMware Aria Suite Lifecycle 8.18.x
VMware Identity Manager 3.3.x

Cause

This issue occurs because a stale IP address is not cleared following an IP reassignment during a failover activity. Generally, once the cluster health normalizes during the inventory sync, the notification changes to Healthy and is reflected in the UI. However, due to this stale entry, the UI persistently shows the cluster as Critical even though there are no actual functional issues.

Resolution

  • This issue is resolved in VMware Aria Suite Lifecycle 8.18 Patch 6 and later versions.
  • To permanently resolve this issue, upgrade VMware Aria Suite Lifecycle to version 8.18 Patch 6 or later