Executing API POST https://<LM_IP>/policy/api/v1/infra/full-sync-action?action=request_full_sync causes error "No active Global Manager exists"
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Executing API POST https://<LM_IP>/policy/api/v1/infra/full-sync-action?action=request_full_sync causes error "No active Global Manager exists"

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Article ID: 436545

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Updated On:

Products

VMware NSX

Issue/Introduction

Below is the screenshot of the error when executing the request_full_sync API:

Environment

VMware NSX

Cause

This issue can happen if the site flows for Policy.GM_2_LM and flows for Policy.LM_2_GM_NOTIFICATION are not in full sync.

Resolution

Part 1: Identify the affected Site:
1) Execute the below API to get an output of sites and its unique IDs:
GET https://<GM_IP>/global-manager/api/v1/global-infra/sites

2) Make a note of the "unique_id" associated to the affected Site:

Example:
            "id": "XYZ",
            "display_name": "XYZ",
            "path": "/global-infra/sites/XYZ",
            "relative_path": "XYZ",
            "parent_path": "/global-infra",
            "remote_path": "",
            "unique_id": "########-####-####-####-############",

Part 2: perform request_full_sync on the site ID retrieved by from Part 1:

1) On the Active GM:
 a. Execute the following API
 curl -k -u admin -H "Content-Type: application/json" -X POST https://localhost/api/v1/federation/replication/sites/########-####-####-####-############/flows/Policy.GM_2_LM?action=request_full_sync
 b. Wait for 10 minutes
 c. Execute the following API
 curl -k -u admin -H "Content-Type: application/json" -X POST https://localhost/api/v1/federation/replication/sites/########-####-####-####-############/flows/Policy.LM_2_GM_NOTIFICATION?action=request_full_sync
 d. Wait for 10 minutes
2) On the LM site which had the issue, i.e.,XYZ
 a. Execute the following API
 curl -k -u admin -H "Content-Type: application/json" -X POST https://localhost/policy/api/v1/infra/full-sync-action?action=request_full_sync
 b. Wait for 10 minutes