Error connecting to a landscape seen in the tomcat log
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Error connecting to a landscape seen in the tomcat log

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Article ID: 43639

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Updated On:

Products

CA Spectrum

Issue/Introduction

The following error connecting to a landscape seen in the tomcat log:

Request to Landscape model ( name - ixxxxx, type - Landscape ) failed due to an unknown error. 

Also, in a fault tolerant environment Spectrum may not show the proper status of the VNM in the OneClick client.

Environment

Release: Any version of Spectrum
Component:

Cause

There are various known causes for this error. The following is a list of a few of the known causes:

1. A firewall is blocking communication between the OneClick and SpectroSERVER systems

2. If on a Linux server, check iptables blocking communication between the OneClick and SpectroSERVER systems

3. Check hostname resolution between the OneClick and SpectroSERVER systems

4. $SPECROOT/.hostrc file not configured correctly

5. Network latency between the OneClick and SpectroSERVER systems

Resolution

Verify the known issues as mentioned in the Cause section.

If all looks good, run a sniffer trace on the SpectroSERVER and OneClick systems to ensure they are communicating properly.