Third Party Plugin Download Fails with UnknownHostException "Name or service not known"
search cancel

Third Party Plugin Download Fails with UnknownHostException "Name or service not known"

book

Article ID: 436374

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Third Party plugins fail to download or deploy, resulting in an error status in the vSphere Client:

Cannot complete the operation. See the event log for details. Error downloading plugin. Make sure that the URL is reachable and the registered thumbprint is correct. 

<FQDN>: Name or service not known

/var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log shows:

[ERROR] sdk-plugin-deployer-######    com.vmware.vise.plugin.status.RemotePluginStatusServiceImpl       DOWNLOAD_FAILED: Error downloading plugin package <package> from https://<FQDN>:<PORT>/static/vsphere-web-client/<PLUGIN>. Reason: Download error. Make sure that the URL is reachable and the thumbprint is correct. 
[ERROR] sdk-plugin-deployer-######    com.vmware.vise.plugin.extension.VcExtensionManager               Downloading plugin package: '<PLUGIN>' registered in vCenter: '<URL> (<ID>)' has failed. java.util.concurrent.CompletionException: com.vmware.vise.plugin.download.PluginDownloadException: java.net.UnknownHostException: <FQDN>: Name or service not known

Cause

vCenter is unable to resolve the plugin appliance endpoint due to malformed <FQDN> or underlying DNS/network connectivity issues.

Resolution

To resolve this issue:

  1. From the vCenter Server shell, confirm that the FQDN provided in the error message is resolvable via DNS.
  2. Confirm that the FQDN registered in the vCenter ExtensionManager matches what's expected.
  3. If the FQDN is unresolvable or incorrect, address the underlying network/DNS issue or update/redeploy the plugin appliance to ensure it's correctly registered with vCenter.