Compute manager connection status is 'Down' due to DNS issue
search cancel

Compute manager connection status is 'Down' due to DNS issue

book

Article ID: 436301

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

Compute manager registration status is 'Registered' but connection status is 'Down'.


Clicking on the 'Down' button in NSX manager UI shows following error -

NSX manager is unable to ping vCenter using fully qualified domain name (fqdn).

Relevant logs -

var/log/cm-inventory/cm-inventory.log
WARN ClusterNodeConfigListener-1-1 VcUtilsImpl 5520 SYSTEM [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="cm-inventory"] Unable to find ip addresses for <compute manager hostname>

var/log/proton/nsxapi.log
FATAL EventReportProcessor-1-2 EventReportSyslogSender 5842 MONITORING [nsx@6876 comp="nsx-manager" entId="####-####-####-####-97c6fa2fa0a2" eventFeatureName="infrastructure_service" eventSev="critical" eventState="On" eventType="compute_manager_lost_connectivity" level="FATAL" subcomp="manager"] Connection status of Compute Manager <compute manager hostname> having id ####-####-####-####-97c6fa2fa0a2 is DOWN.

Environment

VMware NSX

Cause

DNS server is down or unreachable so NSX manager is unable to resolve fqdn of the vCenter.

Resolution

1. Check if DNS server is functional and if there is any connectivity issue between NSX manager DNS server.

2. If the DNS server has changed then update correct DNS server in NSX manager.

  • Get existing DNS servers using the following command:
    get name-servers

  • Update the new DNS server IP using the following command:
    set name-servers <new-dns-server>

  • Delete the old DNS server using the following command:
    del name-server <new-dns-server>

Note: NSX manager uses dig command for DNS forward and reverse lookup. If the configured DNS server doesn't support dig then name resolution will fail even if nslookup works.