Error "Found the following RPMs that are not part of the vCenter Server installation: [oniguruma, vsphere-ui-config, VMware-spherelet_1_29]" reported during vCenter Reduced Downtime Upgrade
search cancel

Error "Found the following RPMs that are not part of the vCenter Server installation: [oniguruma, vsphere-ui-config, VMware-spherelet_1_29]" reported during vCenter Reduced Downtime Upgrade

book

Article ID: 436199

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

During vCenter Server Reduced Downtime Upgrades the user may see an error like:

Previous Error     Found the following RPMs that are not part of the vCenter Server installation: [oniguruma, vsphere-ui-config, VMware-spherelet_1_29]

Resolution     The upgrade process does not preserve any 3rd party RPMs installed on the vCenter Server Appliance. Please re-install any non-standard packages again after the upgrade.

Environment

VMware vCenter Server 8.x

Cause

The RPM pre-check is designed to find RPMs installed by the customer that are not part of the regular vCenter deployment.  In this case, the pre-check is reporting packages which are part of the standard vCenter installation, so this error is false positive.

Resolution

This message is a false positive and can be ignored.  There is no impact to the vCenter upgrade due to this error.

Additional Information

This issue has been fixed in vCenter Server 8.0U3j

VMware vCenter 8.0 Update 3j Release Notes

PR 3681400: During Reduced Downtime Upgrade (RDU) prechecks you see a warning for RPMs that are not part of the vCenter installation

When running an RDU precheck, in the vSphere Client you might see a warning such as Found the following RPMs that are not part of the vCenter Server installation: [oniguruma, vsphere-ui-config, VMware-spherelet_1_29].

This issue is resolved in this release. The fix updates the RPM list.


Japanese Version:
vCenter Server のダウンタイム短縮アップグレードの際にエラー "Found the following RPMs that are not part of the vCenter Server installation: [oniguruma, vsphere-ui-config, VMware-spherelet_1_29]" が発生する