Board view flipping cards after large string update
search cancel

Board view flipping cards after large string update

book

Article ID: 436100

calendar_today

Updated On:

Products

Clarity FedRAMP Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

On board views you flip back to the previous card, when you update a large string field on the Details pane and quickly move to the next card quickly.

STEPS TO REPRODUCE:

  1. Classic Administration > Studio > Objects
  2. On the Tasks object create a large string field: "My Custom Description"
  3. Go to the tasks Workspace and load the Board view.
  4. Ensure a few tasks are present
  5. Add the "My Custom Description" field to the Details pane of the Board view
  6. Select a card on the Tasks board view and open the Details pane
  7. Fill the "My Custom Description" field with any text value
  8. Click on the next Task card

Expected Results: Clarity remains on the newly selected task so you can update the "My Custom Description" field too
Actual Results: Clarity flips to the previously modifid task card

Environment

Clarity 16.3.X, 16.4.0, 16.4.1, 16.4.2

Cause

This is caused by DE185086

Resolution

This is fixed in Clarity 16.4.3

Workaround: Wait some time before you change cards after updating a large string field. Or perform the changes on the grid view instead

Additional Information

This happens on any board view:

  • Tasks workspace
  • Task module on a project/investment
  • Risk/Issues/Changes module on a project/investment...