Failed to retrieve the HCX Manager support bundle
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Failed to retrieve the HCX Manager support bundle

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Article ID: 436082

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Updated On:

Products

VMware HCX

Issue/Introduction

  • Attempting to download a technical support bundle from the HCX Manager UI (port 443) fails after approximately 10 minutes.
  • The downloaded file is only 1 KB in size and contains the following HTML error:
    502 Bad Gateway - The proxy server received an invalid response from an upstream server.
  • In the web.log, you see the following error during the download attempt:
    /common/logs/admin/web.log
    <timestamp> UTC [https-jsse-nio-127.0.0.1-8443-exec-8, Ent: HybridityAdmin, , TxId: TxId: <uuid>] INFO  c.v.v.h.a.t.TechSupportHcspRestController- Posted 'TechSupport
    ServiceJob' for generating TechSupportBundle
    <timestamp> UTC [https-jsse-nio-127.0.0.1-8443-exec-8, Ent: HybridityAdmin, , TxId: TxId: <uuid>] WARN  c.v.v.h.m.k.KafkaProducerDelegate- Publish failed and will retry 
    java.util.concurrent.ExecutionException: org.apache.kafka.common.errors.InvalidPidMappingException: The producer attempted to use a producer id which is not currently assigned to its transactional id.
    <timestamp> UTC [https-jsse-nio-127.0.0.1-8443-exec-8, Ent: HybridityAdmin, , TxId: TxId: <uuid>] INFO  c.v.v.h.m.k.KafkaProducerDelegate- Initializing a new Kafka producer with retries
    <timestamp> UTC [https-jsse-nio-127.0.0.1-8443-exec-10, Ent: HybridityAdmin, , TxId: TxId: <uuid>] INFO  c.v.v.hybridity.utils.DownloadUtils- Downloading file: /tmp/techsupport/HCX-Connector-tech-support-<timestamp>.tar.gz, mime type: application/gzip
    2026-02-20 01:33:42.131 UTC [https-jsse-nio-127.0.0.1-8443-exec-10, Ent: HybridityAdmin, , TxId: TxId: <uuid>] ERROR c.v.v.hybridity.utils.DownloadUtils- Failed to download file: /tmp/techsupport/HCX-Connector-tech-support-<timestamp>.tar.gz
  • The issue persists even when accessing HCX without a proxy or from different network segments.

Environment

VMware HCX

Cause

This issue occurs because of a software limitation in the file size calculation logic for support bundles. When a bundle exceeds 2 GB, the system incorrectly calculates the size. This invalid value causes internal proxies or network routers to reset the connection, leading to the 502 error.

Resolution

Please download the support bundle via the Appliance Management UI (Port 9443).
https://<HCX-Manager-IP>:9443
Navigate to Administration > Troubleshooting > Technical Support Logs