Windows Agent throws "ClosedChannelException" and status code 1005 during File Transfer.
search cancel

Windows Agent throws "ClosedChannelException" and status code 1005 during File Transfer.

book

Article ID: 435955

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine Automic SaaS

Issue/Introduction

When performing a FileTransfer (JOBF) using Windows Agents (v24.x), the following behaviors are observed in the destination agent logs:

  1. Delayed Exception: Approximately 2 minutes after a failed FileTransfer (e.g., due to an incorrect filename), a Java exception is logged: 
U00045014 Exception 'java.nio.channels.ClosedChannelException: "null"' at 'org.eclipse.jetty.websocket.core.internal.FrameFlusher.onClose():227'
U02100051 Web socket connection '...' closed with status code 'No code present (1005)', reason '-'

 

Environment

  • Product: Automic Workload Automation
  • Component: Windows Agent
  • Versions: 24.4.3+hf1, 24.4.4

Cause

This issue is identified as a product defect tracked under DE184781.

Investigation revealed that during a FileTransfer, two WebSocket handles are created. In certain failure scenarios, one of these handles is not properly closed by the agent. After the 2-minute timeout, the unclosed connection triggers the ClosedChannelException and the 1005 (No code present) status message

Resolution

Update to a fixed version listed below or a newer version if available.

Component: Agent Windows

Automic Automation Engine 24.4.5- TBA

Additional Information

Article title: How to register to Broadcom Software Product updates and Critical Alerts

https://knowledge.broadcom.com/external/article?articleId=133819